ItGo.me - 专注IT技术分享

首页 > Exception > 安装hadoop-eclipse-plugin插件出现的问题:Unsupported major.minor version 51.0

安装hadoop-eclipse-plugin插件出现的问题:Unsupported major.minor version 51.0

时间:2015-04-26来源:网友分享 点击:
安装hadoop-eclipse-plugin插件出现的问题:
org/apache/hadoop/eclipse/preferences/MapReducePreferencePage : Unsupported major.minor version 51.0

主要是因为hadoop-eclipse-plugin-1.2.1.jar 编译的jdk版本和eclipse启动使用的jdk版本不一致导致。
修改myeclipse.ini文件即可解决。
#binary/com.sun.java.jdk.win32.x86_64_1.6.0.u43/bin/javaw.exe 改为:
binary/jdk1.7.0_67/bin/javaw.exe
jdk1.7.0_67为自己装的jdk版本

resolution will not be reattempted until the update interval of Nexus has elapsed or updates are forced解决

/nexus/content/groups/public was cached in the local repository, resolution will not be reattempted until the update interval of Nexus has elapsed or updates are forced...

安装hadoop-eclipse-plugin插件出现的问题:Unsupported major.minor version 51.0

安装hadoop-eclipse-plugin插件出现的问题: org/apache/hadoop/eclipse/preferences/MapReducePreferencePage : Unsupported major.minor version 51.0...

java.lang.OutOfMemoryError: Java heap space

FATAL org.apache.hadoop.mapred.Child: Error running child : java.lang.OutOfMemoryError: Java heap space...

安装hadoop-eclipse-plugin插件出现的问题: org/apache/hadoop/eclipse/preferences/MapReducePreferencePage : Unsupported major.minor version 51.0
------分隔线----------------------------